[tulip] LNE100TX... not solved

Donald Becker becker@scyld.com
Thu, 14 Dec 2000 20:21:46 -0500 (EST)

On Thu, 14 Dec 2000, Erik Steffl wrote:

>   I have the same card, same problem (or similar). I have tried all the
> drivers (current latest, current test, some patches from Dan Hollis) but
> nothing helps so far. Is this card considered working? Under
> development? Ignored?

The ADMtek Centaur 985 chip does work, and frequently tested.

The tulip driver is under active development -- I've spent about six hours
on it this week, including tracking down a bug that only occured on fast
(over 800Mhz) systems, using memory-mapped access to boards with slow
EEPROMs.  The bug corrupted only the high bit of EEPROM word #32 (!), and
looked like a transceiver selection problem. 

> > tulip-diag.c:v2.04 9/26/2000 Donald Becker (becker@scyld.com)
> > Index #1: Found a ADMtek AL985 Centaur-P adapter at 0xa800.
> >  Port selection is 100mbps-SYM/PCS 100baseTx scrambler, half-duplex.

Note that 985 reports unusual values for the media settings, so the
'tulip-diag' report is usually wrong.  This is a 'tulip-diag' bug, and it
will be fixed in an upcoming release.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993