[tulip] ADMtek Centaur Card isn't recognized...

Mr V (Note my email change!!!) volentib@netmdc.com
Mon, 11 Dec 2000 19:18:31 -0700

Hash: SHA1

I've tried everything I can think of to get this card recognized.  The
card is a Network Everywhere NC100 V2.1.

The only code I can get to successfully compile is tulip-diag.  Tulip.c
gives me errors, and I've tried using 'kgcc' instead of 'gcc' due to having
installed RH7.

Anyway, tulip-diag reports the following, which includes a 'PCI bus error!:
unknown 7':

tulip-diag.c:v2.04 9/26/2000 Donald Becker (becker@scyld.com)
Assuming a Digital Tulip series adapter at 0xb800.
 Port selection is 100mbps-SYM/PCS 100baseTx scrambler, full-duplex.
 Transmit started, Receive started, full-duplex.
  The Rx process state is 'Transferring Rx frame into memory'.
  The Tx process state is 'Closing Tx descriptor'.
  PCI bus error!: Unknown 7.
  The transmit unit is set to store-and-forward.
 Interrupt sources are pending!  CSR5 is ffffffff.
   Tx done indication.
   Tx complete indication.
   Tx out of buffers indication.
   Transmit Jabber indication.
   Link passed indication.
   Tx FIFO Underflow indication.
   Rx Done indication.
   Receiver out of buffers indication.
   Receiver stopped indication.
   Receiver jabber indication.
   Link changed indication.
   Timer expired indication.
   Link failed indication.
   PCI bus error indication.
   Early Rx indication.
WARNING: The EEPROM is missing or erased!
 This interface is missing the EEPROM.
  This is likely the non-primary interface on a multiport board.
 Use '-a' or '-aa' to show device registers,
     '-e' to show EEPROM contents, -ee for parsed contents,
  or '-m' or '-mm' to show MII management registers.

Also, an insmod on the tulip.o that DOES compile outputs the following (this
is after I finally got past all of the 't_busy' errors, etc):

unknown symbol pci_drv_unregister (or unresolved - didn't get the output in
unknown symbol pci_drv_register

FYI, the card works fine under Win98 - it isn't a hardware problem.  I've
tried a cold boot with and without PnP BIOS enabled, tried LILO ether=
- - nothing works.  At boot up I get an error saying the module wouldn't
Something like 'IO or IRQ parameters could be incorrect.'

I can't think of any other pertinent info right now.  Please let me know if
additional info will help.  I'm debating a RH6.2 install just to see if
recognize the card.  Thanks for the help, and please send me a direct email
if you post to the group.

Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>