KNE100TX furious activity

Brian D. Haymore
Sun Nov 21 23:28:25 1999

simple fix.  you are probably useing version .89 of the tulip driver
supplied with your distribution.  I have found a way around this issue to
install if you haven't already been able to.  First you need to install
using expert mode or whatever your dist calls it that will allow you to
specify the network driver you want.  Choose the de4x5 driver.  If you are
attached to a switch you will need to place a hub between you and the
switch as this combo of the de4x5 and the tulip (intel flavor) don't do
well on switches.  This should now allow you to get up and going.  After
which you should get teh .90 or later version of the tulip driver to get
things going their proper way.

Brian D. Haymore
University of Utah
Center for High Performance Computing
155 South 1452 East RM 405
Salt Lake City, Ut 84112-0190

Email: - Phone: (801) 585-1755 - Fax: (801) 585-5366

On Sun, 21 Nov 1999, Ed Snible wrote:

> I have two Kingston KNE100TX tulip cards (which work under Win98.)  Under
> Linux, the 'activity' light on both the cards and the hubs flash furiously,
> and the cards can't ping each other.
> Using a SOHOware 10Mbps hub the 'partition' light comes up (indicating a port
> has been found to be faulty and has been isolated.)  Both the SOHOware hub and
> a D-Link DSS-5+ 10/100 "switch" I'm using for test begin flashing their
> activity lights starting when I issue "ifconfig eth0 up".
> I'm using Redhat 6.0 (2.2.5-15, unmodified, with tulip.c v0.89H) on an Asus
> P2B motherboard.  Any advice greatly appreciated -- this is my home LAN, and
> my first Linux ethernet (I work for IBM where life is token ring).  The other
> machine is an Asus socket 7 MB with AMD CPU, Redhat 6.1, tulip 0.89 with
> identical KNE100TX and exhibits identical symptoms.
> I'm attaching the output of ifconfig and tulip-diag.  Any advice greatly
> appreciated.  I've tried using the "options tulip options=" settings to force
> the cards into 10Mbps mode and they exhibit the same flashing 'activity' but
> at 10Mbps.  I haven't tried the 0.91 driver yet (I don't have Linux source
> installed.)
> # /sbin/ifconfig eth0
> eth0      Link encap:Ethernet  HWaddr 00:C0:F0:3B:66:AE  
>           inet addr:  Bcast:  Mask:
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:10 dropped:0 overruns:0 frame:0
>           TX packets:0 errors:6 dropped:0 overruns:0 carrier:18
>           collisions:0 txqueuelen:100 
>           Interrupt:10 Base address:0xb800 
> # ./tulip-diag -m
> tulip-diag.c:v1.19 10/2/99 Donald Becker (
> Index #1: Found a Digital DS21143 Tulip adapter at 0xb800.
>  Port selection is 100mbps-SYM/PCS 100baseTx scrambler, half-duplex.
>  Transmit started, Receive started, half-duplex.
>   The Rx process state is 'Waiting for packets'.
>   The Tx process state is 'Idle'.
>   The transmit threshold is 128.
>   The NWay status register is 000020c6.
>  MII PHY found at address 1, status 0x782d.
>  MII PHY #1 transceiver registers:
>    1100 782d 0016 f831 01e1 41e1 ffff ffff
>    ffff ffff ffff ffff ffff ffff ffff ffff
>    0022 ff00 0870 fff0 0008 ffff ffff ffff
>    ffff ffff ffff ffff ffff ffff ffff ffff.
>   Internal autonegotiation state is 'Ability detect'.
> Ed Snible