Linksys 10/100 PNIC on 486

John Sutherland
Sat May 8 14:36:52 1999

I'm having problems with the Linksys 10/100 PNIC based cards..

I'm running on an old 486, AMD 133/ OC'ed to 160, kernel 2.2.2, with tulip.c of
v.91..  This is my Masquarding machine, so I have 2 cards (both the same).. One
card to the cable modem, the other to internal... The cable modem will
only operate at 10Mbit, which is fine, and works great.. My probelm is getting
the internal one to work at 100M... Network desciption: total 3 machines.. 486-
the one with the problems.. One laptop with 10M card, one PII350 with another
Linksys 10/100 card.. 

If I set my network up with a 10/100 hub, the card is deteched at 100M, but I
can not get any communications what so ever across it.. The activity light on
the card itself does blink with activity though... If I plug the card into a
10M hub, everything works fine (after a ifdown/ifup).. 

I compile my drivers directly into the kernel, so just adding an options line
for modules doens't help me.. I've changed the option[] var to have 13 and 3..
Niether worked.. I've also tried removing one card out of the system (putting
in my old 3c503), and same results...

so my question is, Does the driver support 100M on 486's????