broadcast recieve problem with FA310TX and RH 5.2

Anthony Rumble
Sun Mar 21 07:35:59 1999

System :-
 Intel PI 450
 AUSTek Duel PII Mobo (one CPU fitted)
 RedHat 5.2 with all the errata and 2.0.36 kernel

I have tried both the stock 2.0.36 tulip.c driver, as well as the Netgear
modified v0.89k tulip.c that comes on their driver disk..

When the machine boots detects the card, configures it fine...

But if I try pinging any hosts on my ethernet, nothing..

Now.. I run tcpdump to see whats going on.. and suddenly it works.

The thing I have noticed is that tcpdump puts the interface in promisc
mode, and when in this mode it seems to see the ARP responces fine... but
when not in promisc, it fails badly.

This is probably a problem with the driver code? Is there a fix? is there
some obscure other combination that is causing this? (Like multicast for

I am desperate for an answer, as this is about to be shipped to a client,
and I really don't want to have to replace the cards with NE2000's to get
it out the door..

I never used to have problems with these cards when they were Pre-LiteOn
 digital chips...

Anthony Rumble
EMUSYS Unix Consulting Phone: 0500 500 EMU
Direct 02-9798-7604 Mobile 0412-955-042  Fax 02 9798 2854