[LRP] Dec Tulip based NICs

Brian D. Haymore brian@loki.chpc.utah.edu
Tue Jul 27 11:26:15 1999

I have the KNE100TX.  I have around 38 of them with the 21140 chips and 49
of them with the new intel 21143-pd tulip chip all in use on our beowulf
cluster. http://loki.chpc.utah.edu

I use the de4x5 driver for the installation process because the install
disks are using a kernel that still uses the .89 version of the tulip
driver.  You probably have to run in whatever the "expert" mode is for
your distribution so thast you can stop any autodetection as it will
probably try to load the tulip and you want to select the de4x5.  The
support of the de4x5 driver seems to be just beyond usable for the
KNE100TX.  By this I mean that the driver seems to get you working but
will have trouble with DNS lookups for the host name at times, so just
feed it in by hand.  But you can get up and going.

Brian D. Haymore, Systems Administrator
Center for High Performance Computing
University of Utah
Email: brian@chpc.utah.edu
Phone: (801) 585-1755

On Mon, 26 Jul 1999, Tom Zacharoff wrote:

> At 06:56 PM 7/26/99 -0600, you wrote:
> >Use the de4x5 driver to get installed on, then update to a newer tulip
> >driver and life will be happy for you.....
> >
> >On Mon, 26 Jul 1999, Tom Zacharoff wrote:
> >
> >> I just bought two Kingston KNE100TX boards with the new 21143 chipset. They
> >> both don't work. I've tried to boot from a dos floppy to use Kinston's own
> >> "Qstart" dos based testing software they ship with it. The most basic test
> >> shows "No Link Pulse Detected". These are connected to a 3COM 4 port 10 base
> >> T hub. I called Kinston's tech support and they said lots of people are
> >> having problems with these newer boards. They are shipping me two cards
> >> based on the older 21140 chipset by Fedex Priority Overnight (P1).
> >> 
> >> BTW I was just trying to get some good PCI NICs for an ip masquerading
> >> firewall based on the Linux Router Project. If I can't get their own dos
> >> based testing software to show a positive result... that's pretty bad.
> >> Kingston's kicking in with a quick RMA though. It remains to be seen how
> >> well this works out.
> I forgot to mention I tried both the tulip *and* the de4x5 driver. Both
> don't work with the 21143-based Kingston KNE100TX.
> ----------------------------------------------
> Tom Zacharoff
> ESSCOR, Inc.
> System Administrator
> (619) 481-9126 x140