A problem about a DEC 21143PA 10/100M card

Trevor zjtao@nudt.edu.cn
Sat Sep 5 04:20:33 1998

  I have a problem with tulip.c when using my DEC evaluating board
21143PA 10/100M card,the physical layer chip is MicroLinear ML6692.
  The tulip.c don't work in my Linux2.0.30,but when I changed for a
Accton 21143PC Card, the driver worked well.
  I tried to set the media(10Base-T)  by hand,not using
auto-negotiation,but it don't
work either.
  I have tried the driver  de4x5.c,it can drive  my card in 10base-T
mode, but it don't work
in MII-100BASE-T either.it report "unsupport media,...".
  So I suspected my card for 100M working mode,but it worked very well
in Win95,not only
in 10M mode,but also in 100M mode.
  When I used my card in Digital Unix 4.0D,it can work in 10M mode,but
when set it to 100M,the driver report: "no srom info for selected media.
"     I have rewrite the srom  to
several other appropriate values,but it still don't work.
  If someone have known this problem,please tell me why, for I have to
use the card.
Thank you!