[tulip-bug] media type selection errors with SMC8036TX cardbus adapter (ADMTek Comet chip)

Juhan Ernits juhan@cc.ioc.ee
Fri Nov 15 11:37:10 2002

Thanks for the fast response,

On Fri, 15 Nov 2002, Donald Becker wrote:

> If you limit your advertised capabilities to full duplex, the
> transceiver will not pass packets to a link partner without
> autonegotation.  See
>   http://scyld.com/expert/NWay.html

Ok, but the default should not exclude half duplex. I am not aware of
excluding it.

> > ********* Link partner is a Cisco Catalyst 1900 switch (2x100, 24x10
> Ohhh, as soon as I see "Cisco", I _expect_ duplex problems.
> Do you have non-Cisco equipment that you can test against?

The same behaviour in 10baseT-HD mode appears with a ne2000 (Accton 1656
or sth) on the other end of a crossed cable. Also tried it with a dumb
3Com 24x100Mbit switch. This cisco seems to work fine
with 10baseT-HD and FD. Tried it many times and have seen what it looks
like when HD nic is attached to a FD port (ping passes but e.g. file
transfer extremely sluggish). 10 Mbit ports do not support autonegotiation
either, so it should not be the problem here.

> > (It seems that mii-diag can set 10baseT-FD and 100baseT-HD, but not the
> > other media types)
> How are you calling the 'mii-diag' program?  I suspect that you actually
> specifying full duplex.

mii-diag -F 100baseTx-HD
mii-diag -F 100baseTx-FD
mii-diag -F 10baseT-FD
mii-diag -F 10baseT-HD

> > 2) The card/driver is not able to switch itself into 10baseT-HD mode (even
> > in autosense mode).
> I the debug log doesn't show that.

Ok. I was not clear enough here. The card says it switches, (even the led 
turns from green to yellow), but i still get the behaviour as if i were
connected to a FD port with HD card (ping goes through, but larger things 
don't). The output of ifconfig illustrates the situation (notice the
TX errors, they start incrementing in 10baseT-HD mode):

eth0      Link encap:Ethernet  HWaddr 00:04:E2:4B:86:CB  
          inet addr:  Bcast:  Mask:
          RX packets:178726 errors:1 dropped:17 overruns:0 frame:2
          TX packets:415209 errors:364287 dropped:0 overruns:0 carrier:515049
          collisions:0 txqueuelen:100 
          RX bytes:26217113 (25.0 MiB)  TX bytes:563868979 (537.7 MiB)
          Interrupt:9 Base address:0xa000   

> > ********* The card works with 10baseT-FD, (only when forced into this
> > mode, but that's fine).
> > 
> > Tulip-diag with 10baseT-FD media attached (working fine):
> ...
> >  MII PHY #1 transceiver registers:
> >    0100 784d 001d 2411 05e1 0021 0004 2001
> ...
> >  Basic mode control register 0x0100: Auto-negotiation disabled!
> >    Speed fixed at 10 mbps, full-duplex.
> OK, so the speed and duplex were forced, and it works fine.  Note that
> configuring the switch to forced full duplex is a not a standard
> conforming mode!  Even Cisco now admits that their earlier
> recommendation to force duplex was in error and a deliberate attempt to
> put more work on Donald Becker.  (Errrm, well, that latter part is
> implicit in the document.)

i have only a few marked ports in the swich that have 10baseT-FD
ports. The rest are standard HD. Tried both in relevant situations.

> > ********* Tulip-diag with 10baseT-HD media attached in autosense mode (not
> > working fine):
> Does it pass packets?  Are there performance problems?

Passes packets. Performance problems. TX errors.

> >  MII PHY #1 transceiver registers:
> >    1100 786d 001d 2411 05e1 0021 0006 2001
> >  Basic mode control register 0x1100: Auto-negotiation enabled.
> >  Basic mode status register 0x786d ... 786d.
> >  Link partner capability is 0021: 10baseT.
> >    Negotiation did not complete.
> You should be able to communicate.

Nop. ping passes, but any longer packets don't...

Is there anything else i could try?


Juhan Ernits