[tulip-bug] KNE111TX PNIC-II problems....(and KNE110TX with 0.92t driver)

Simen Timian Thoresen simentt@dolphinics.no
Wed, 2 May 2001 13:37:49 +0200

Ok, I now have some more datapoints. First the Kingston KNE111TX (LiteOn 
PNIC-2 card);

I reported that the card/driver would drop tcp and udp transfers without 
loosing the connection. For instance would a ftp session stop after a few 
(60ish) Kbytes, and also cp commands on nfs-mounted drives would lock. In 
all cases retrying the transfer would work nicely, but with the same result.

This was with the kernel-included driver, 0.91ppcsomething, from the 2.2.16-
2.2.19 kernels

I tried the 0.92t driver from scyld, and in a different system that worked 
nicely. I later learned that the kernel-included driver had no problems on 
another different system with these cards, so my initial observation was 
either flawed, or this problem is limited to 10Mbps no-duplex. (all success 
reports are from against 100Mbps FD switches).

When I already had started experimenting with the v0.92t driver, I installed it 
on a machine with KNE110TX cards (These are PNIC cards with MII 
trancievers). The 0.92t driver still has the same problem as reported earlier - 
when connected to a 100mbps-FD link the card works nicely, but if the link 
goes down (switch is powercycled), renegotiation fails, bringing the card up 
with a non-working half-duplex link - ifdown and ifup'ing the interface will in 
some cases get the link working again, but still only at half duplex. While the 
link is not working, no packets sent reach the switch, so to a user all 
packets seem to be lost.

I'll still be able to supply additional debugging info for a few days before if 
somebody is interested in looking it over.

Why are there penguins embedded in my toaster?

Er det rart?
The gnu RART-project on http://valinor.dolphinics.no:1080/~simentt/rart