[tulip-bug] Problems with kne111tx

Tom Parker palfrey@bits.bris.ac.uk
Sun, 19 Aug 2001 17:50:34 +0100

I'm running a linux router/server off my cable modem, and I've been 
having a little problem with it.  The two network cards in it are both 
KNE111TX's, and it seems that if traffic flow goes anything higher than 
about 100 kb/s (rough guess, figure may be higher, but the value is 
significantly lower than what the 10mb network can do) that we get a 
collision light on the hub, and also tcpdump reports my computer waiting 
for a sequence number that the server does not ever give out until it 
times out for the server to respond, with no luck. The first few packets 
get through, but then everything messes up.

In other words, traffic to/from the 'net is fine, but any sort of file 
transfer across the LAN is impossible.  I've tried using several 
different protocols (SMB, HTTP, FTP), all with the same results. The 
server talks to the LAN fine at low speeds, but once we get to anything 
higher, it cuts off. One example was with telnet, normally fine, but it 
cut out when I was cat'ing my /var/log/messages, because of the data 
flow rate exceeding temporarily whatever the limit is.

I'm using a 2.4.9 kernel (same problems earlier with both 2.4.4 and 
2.4.7). This did have the 0.9.5-pre16 tulip driver, and I'm now trying 
the 1.1.8 driver, same results with both. I've also tried this with 
another computer on the LAN, same results there. My system is running 
Windows '98, the other test system was running Windows Me.

Any ideas? Because this is me completely lost here.


Tom Parker

"And the beast shall be made legion. Its numbers shall be increased a 
thousand thousand fold. The din of a million keyboards like unto a great 
storm shall cover the earth, and the followers of Mammon shall tremble." 
- From The Book of Mozilla, 3:31 (Red Letter Edition)