Problem with latest tulip driver and AsanteFAST 10/100 card

Noah Friedman
Fri Feb 4 07:34:29 2000

I have an old-ish Asante 10/100 card based on the DEC 21140 chip.
Trying to load the driver results in the following kernel messages:

    Found Digital DS21140 Tulip at PCI I/O address 0xf880.
    tulip.c:v0.91g-ppc 7/16/99
    eth0: Digital DS21140 Tulip rev 18 at 0xf880, 00:00:94:75:4C:DC, IRQ 10.
    eth0: Old format EEPROM on 'Asante' board.  Using substitute media control info.
    eth0:  EEPROM default media type Autosense.
    eth0:  MII interface PHY 0, setup/reset sequences 0/0 long, capabilities e0 78.
    eth0:  Index #0 - Media MII (#11) described by a 21140 MII PHY (1) block.
    eth0:  Advertising 01e1 on PHY 0 (0).
    eth0: Using media type MII, CSR12 is ff.
    eth0: ***WARNING***: No MII transceiver found!

I get no network connectivity using this card; other cards (e.g. netgear)
work fine.  I've tried all the options=n parameters with the Asante card to
no avail.

Running tulip-diag reports:

    tulip-diag.c:v1.19 10/2/99 Donald Becker (
    Index #1: Found a Digital DS21140 Tulip adapter at 0xf880.
     Port selection is MII, half-duplex.
     Transmit stopped, Receive stopped, half-duplex.
      The Rx process state is 'Stopped'.
      The Tx process state is 'Stopped'.
      The transmit threshold is 128.
       No MII transceivers found!

Has anyone else experienced this problem?  The card previously worked ok
with Solaris so I'm reasonably sure it's not defective.
To unsubscribe send a message body containing "unsubscribe"