Newbie question

Ed Snible
Mon Nov 15 22:22:06 1999

I am new to Linux.  I have two Kingston KNE100TX tulip cards.  I installed
Linux and it found the cards but they could not ping each other.  I suspected
link speed problems (the cards are 100mbps, but my SOHOware four port hub is
10mbps).  I tried some stuff on the cesdis page and came here.

Any help greatly appreciated, I'm attaching the output from insmod, ifconfig
up, and tulip-diag:

# /sbin/insmod tulip.o debug=3 options=9
(/var/log/messages reports)
... kernel: tulip.c:v0.89H 5/23/98 Nov 15 21:55:03
asus kernel: eth0: Digital DS21142/3 Tulip at 0xb800, 00 c0 f0 3b 66 ae, IRQ
xxx kernel: eth0:  EEPROM default media type Autosense. 
... kernel: eth0:  MII interface PHY 0, setup/reset sequences 0/0 long,
capabilities e0 78. 
... kernel: eth0:  Index #0 - Media MII (#11) described by a 21142 MII PHY (3)
... kernel: eth0:  MII transceiver found at MDIO address 1, config 3100 status
... kernel:   PCI latency timer (CFLT) is 0x20,  PCI command is 0017. 

# /sbin/ifconfig eth0 up
(var/log/messages reports)
... kernel: eth0: Using user-specified media MII 10baseT. 
... kernel: eth0: 21142 negotiation status 000000c6, MII. 
... kernel: eth0: 21142 negotiation failed, status 000000c6. 
... kernel: eth0: Testing new 21142 media 100baseTx. 
... kernel: eth0: The transmitter stopped!  CSR5 is f0678006, CSR6 b3862002.

# tulip-diag -m
tulip-diag.c:v1.19 10/2/99 Donald Becker (
Index #1: Found a Digital DS21143 Tulip adapter at 0xb800.
 Port selection is 100mbps-SYM/PCS 100baseTx scrambler, half-duplex.
 Transmit started, Receive started, half-duplex.
  The Rx process state is 'Waiting for packets'.
  The Tx process state is 'Idle'.
  The transmit threshold is 128.
  The NWay status register is 000000c6.
 MII PHY found at address 1, status 0x782d.
 MII PHY #1 transceiver registers:
   3100 782d 0016 f831 0021 0021 ffff ffff
   ffff ffff ffff ffff ffff ffff ffff ffff
   0022 ff00 0000 fff0 00a0 ffff ffff ffff
   ffff ffff ffff ffff ffff ffff ffff ffff.
  Internal autonegotiation state is 'Autonegotiation disabled'.

Any ideas?
PS: If it helps, I'm using PII-400, Asus P2B, Redhat 6.0.  The cards
and hub have worked in the past under Windows98.