Followup: Netgear missing ARPs

Neale Banks
Wed Jun 30 18:39:23 1999

On Wed, 30 Jun 1999, William J. Earl wrote:

>       My testing with the FA310TX and tulip.c v0.91 4/14/99 is entirely
> consistent with what you saw:  hub (not switch), traffic to the other node,
> system with the FA310TX sees the ARP request but not the reply, and a third
> system on the hub can see all the packets (request and reply) just fine.

Good, at least we are seeing the same bug.

> Turning on promisc did cause the ARP to succeed, but my 2.2.9 kernel
> then hung soon (a few minutes) afterward.  (I have not tracked down
> the hang so far.)  

Ah, yes, I forgot the promisc bit - at Keith's suggestion I tried this and
consistently that turning on promisc made the bug go away.  But, turning
on and immediatedly turning off promisc after "ifconfig up"ing the
interface didn't help (seems the interface needed to be in promisc at the
time of the arp).

Anyone got any ideas as the the potential significance of this bit?

My testing was with kernel 2.0.36, glibc 2.0.7, drivers 0.89, 0.91, 0.91e
and some bleeding edge fixes on 0.91e.  No change to the missing arp
problem across these versions.

Also, the missing arp bug persisted (as far as I could tell, identically)
with the netgear-supplied Tulip driver (which is based on a now really old
Tulip driver and may suffer from other problems).

As for the hang you esperienced, I suspect that is an unrelated problem
that _might_ be addressed in fixes in 0.91e or other fixes pending.  Have
you tried the 0.91e tulip driver?  There are also some post-0.91e bugfixes
kicking around - I wouldn't be surprised if we see a new development
driver soon, it may be worthwhile for you to try that.

Anyone got any other points to add to make a convincing case to Netgear