Hitachi VB7590 - tulip.c v0.89K - skput panic

Charles Howes
Thu Oct 15 11:39:59 1998


Mr. Becker, I want to thank you for doing such a great job on all of
the drivers you've worked on; it's really made a difference to a lot of

I guess I'm on the bleeding edge of technology here; my new laptop has
a problem with its ethernet stuff.  Can you help?

The context:

  I've got a Hitachi Visionbook Pro 7590.
  I'm running Slackware 3.5, Linux Kernel 2.0.35.
  I got and installed tulip.c.v0.89K as part of the kernel, not a module.
  Boot messages indicate that the ethernet card is a Digital DS21143 Tulip.

The problem:

  If I plug in an ethernet cable, it crashes the system.  10-baseT
  network, cheap hub or expensive hub, during boot or after.

  Kernel panic: skput:over: 00198008:16530
  In swapper task - not syncing

The initialization messages:

  tulip.c:v0.89K 8/8/98
  eth0: Digital DS21143 Tulip at 0xfc00, 0080c7 49 4c 71, IRQ 11.
  eth0:  EEPROM default media type Autosense.
  eth0:  Index #0 - Media MII (#11) described by  a 21142 MII PHY (3) block.
  eth0: Checking for MII transceivers....
  eth0:  MII transceiver found at MDIO address 17, config 1000 status 7809.
  eth0:  Advertising 01e1 on PHY 17, previously advertising 01e1.

The occasional link-dead message:

  eth0: No link beat on the MII interface, status then 7809 now 7809.

Is there anything else you need to help debug this?
Has the problem been solved in a more recent version of tulip.c?

I've tried using the de4x5.c driver, but it crashed in a more spectacular
fashion at boot, with or without an ethernet cable present.

Thanks!  You're doing an incredible job for the Linux cause!
Charles Howes --
The code was willing.
It considered your request,
but the chips were weak.
  -- Haiku error message