[Realtek] Upgraded memory, RTL8139 lost IRQ

tony van lingen lingent at tpg.com.au
Sun Apr 10 04:38:39 PDT 2005

G'day All.

I've got a bit of a tricky problem. My NIC (NoName, with RealTek 8139 
chipset) used to work perfectly, until I stuck a new 500MB memory stick 
in. From that point on the card did not get an IRQ anymore. I've tried 
every BIOS setting. The BIOS was set to "NO" PnP OS, and everything else 
default. I tried the following BIOS settings:

- set the PnPOS to 'YES'
- set the PnP OS to NO and IRQ to PIC (default is APIC)
- set the PnP OS to NO and reserved IRQs for slot 1 to 3 to 9-11 resp. 
(which should get the card IRQ 10, as it's in slot 2)

The OS, which is RedHat 8, reports SIOCSIFFLAGS - device busy. The 
rtl8139-diag utility reports that the card has no IRQ and /proc/pci has:
  Bus  0, device   0, function  0:
    Host bridge: Silicon Integrated Systems [SiS] 650 Host (rev 1).
      Master Capable.  Latency=32. 
      Non-prefetchable 32 bit memory at 0xe8000000 [0xebffffff].
  Bus  0, device   1, function  0:
    PCI bridge: Silicon Integrated Systems [SiS] 5591/5592 AGP (rev 0).
      Master Capable.  No bursts.  Min Gnt=8.
  Bus  0, device  15, function  0:
    Ethernet controller: Realtek Semiconductor Co., Ltd. 
RTL-8139/8139C/8139C+ (rev 16).
      Master Capable.  Latency=32.  Min Gnt=32.Max Lat=64.
      I/O at 0x9800 [0x99ff].
      Non-prefetchable 32 bit memory at 0xe5800000 [0xe58001ff].

Clearly the card is there, the system sees it but it does not get the IRQ.

My system is:
    - ASUS motherboard (SiS chipset), PentiumIV
    - 768MB RAM (up from 256)

The NIC is the only PCI card, the other 2 slots are empty. Video and 
Audio are on-board and continue to work fine.

Does anyone know how to tackle this? Has the RealTek 8139 chipset a 
problem with this amount of memory or should I suspect the PCI bridge?


More information about the realtek mailing list