[realtek] kernel-module mismatch with RTL8139 - short fix

Umair Yousufi Umair Yousufi" <Umair.Yousufi@UTSouthwestern.edu
Sat Jun 8 21:11:00 2002

Here's the short version of my previous fix (mostly just commands).
See the previous post for the details.

Umair Yousufi

download source files from

cd to download directory
rpm -ihv netdrivers-3.1-1.src.rpm
cd usr/src/pakages/BUILD/netdrivers-3.1
comment out all lines in source containing MODULE_LICENSE
tar -cf netdrivers.tar *
gzip netdrivers.tar
mv netdrivers.tar.gz /usr/src/packages/SOURCES/netdrivers.tgz
cd /usr/src/packages
rpm -bb SPECS/netdriver*.spec
rpm -i --force RPMS/i386/netdrivers-3.0-1.i386.rpm
cd /etc/
edit modules.conf
  //add the following 2 lines to modules.conf:
  alias eth0 rtl8139
cd /lib/modules/2.4.0-4GB/net
depmod -a
modprobe rtl8139
ifconfig eth0 up
here, I used SuSE's LAN setup tool to set eth0 as DHCP.  After it stopped
restarted the network, it worked

> Message: 8
> Date: Wed, 05 Jun 2002 07:09:43 -0500
> From: "Umair Yousufi" <Umair.Yousufi@UTSouthwestern.edu>
> To: <realtek@scyld.com>
> Subject: [realtek] kernel-module mismatch with RTL8139 (resend)
> (this is a resend due to bad formatting)
> I'm trying to get a D-Link DFE-530Tx+ (revD1) ethernet
> card running on a SuSE Linux 7.1 machine.  PCI Vendor
> ID is 1186 and PCI Device ID is 1300 on the card.
> I've installed the updated network driver files
> (netdrivers-3.1-1), and then do 'depmod -a'.  In
> the /lib/modules/'uname -r'/net/ directory,
> running 'modprobe rtl8139' I get the following error
> (paraphrased):
> pci-scan.o:  kernel-module mismatch
>   pci-scan.o was compiled for kernel version 2.4.0
>   while this kernel is version 2.4.0-4GB
> ...then the standard insmod errors show up.
> IMHO, it seems like it should work, but that there is
> some problem related to reporting of which linux
> versions are acceptable.  I've tried previously using
> with both the netdriver3.0 and netdriver3.1
> files.  With the 3.1 files, I ran 'rpm -bb
> SPECS/netdriver*.spec' and also got errors which were
> related to kernel version.  I traced those errors, to
> a kern_compat.h file, which excluded the definition of
> MODULE_LICENSE shows up in the driver and pci-scan
> files).  I'm not exactly sure how to interpret this.
> Any ideas?  I've tried a long time myself, searched
> the archive, etc. and am at wit's end.  I've added
> exerpts from some output from a few commands, if it
> helps.  As a last resort, I may try compiling the
> version that came on the floppy w/ the ethernet card
> (as someone in the archive suggested).
> much thanks
> --
> Umair Yousufi

> -----------cat proc/pci--------------------
>   Bus  2, device   9, function  0:
>     Ethernet controller: Unknown vendor Unknown device (rev 16).
>       Vendor id=1186. Device id=1300.
>       Medium devsel.  Fast back-to-back capable.  IRQ 9.
>       Master Capable.  Latency=32.  Min Gnt=32.Max Lat=64.
>       I/O at 0xb800 [0xb801].
>       Non-prefetchable 32 bit memory at 0xee800000 [0xee800000].
> ----------------------lsmod---------------------------
> Module                  Size  Used by
> mousedev                3856   0  (unused)
> hid                    11680   0  (unused)
> input                   2880   0  [mousedev hid]
> usb-uhci               19056   0  (unused)
> usbcore                45104   1  [hid usb-uhci]