[realtek] Pbm with 2.4.9 -> 2.4.17 8139 driver

François B user@maison.homelinux.net
Sun Jan 13 13:10:00 2002

Happy new year for everybody and forgive me for my english, I'm

I have a Cyrix 166 routeur with USB Alcatel Speedtouch and a 8139 card.
A fact is that the card don't work well in 100base-TX but work perfectly
in 10baseT-HD mode under the 2.4.3 Kernel.

But it seems that there is a bug in ip_conntrack and the kernel crashed
sometimes when it received a big packet for a connexion with disappear
from ip_conntrack table.
I read that this bug is solved in 2.4.x kernel, x>=9.

I tried 2.4.x kernel with x=9, 12, 15 and 17 and I have always the same
The connexion with the RTL8139 card is hashed in general (a big packet,
time with anything, another big packet, time with anything,...) and very
slow under ftp.

I tried to put the 2.4.3 driver on 2.4.17 (changing the 8139too.c file)
but link of kernel failed. I tried to put 2.4.9 ip_conntrack on 2.4.3
but it's a "big bazar" and seems to be difficult.

Do you have any indication to solve my pbm.

Thanks to have read this.

F. Boisson