[realtek] insmod rtl8139 problem

Donald Becker becker@scyld.com
Tue Feb 19 12:58:03 2002

On Mon, 18 Feb 2002, rob.geelen wrote:

> I'm running RedHat 7.2, kernel version 2.4.9
> I downloaded the source rpm for netdrivers3.1-1
> Everything seems to have installed correctly.
> .
> When I run insmod rtl8139.o, I get two messages :
> unresolved symbol pci_drv_unregister
> unresolved symbol pci_drv_register
> .
> I have read one should run insmod pci-scan first !

Correct.  (I left this in just for the archives...)

If you run 'modprobe' it will automatically load pci-scan first.

> when I run insmod pci-scan that runs fine, but now, when trying to run insmod 
> rtl8139 again, I get the following:
> init_module: No such device
> .
> I'm puzzled here,
> Can anybody help me on this one ??

This is reporting that no recognized device was found.

What does 'cat /proc/pci' or 'lspci' report as the numeric ID of the

It's possible that your card has a new, unrecognized PCI ID.
My guess is that you actually have a Myson 803 chip, which some board
vendors print with "8139".  Myson makes a better chip, but the rtl8139
chip is much better known, so I guess that they are trying to trade off
the well-known number.  That's not illegal in the U.S. (numbers can not
be trademarked), but it is unnecessarily confusing.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993