[realtek] 8139C transmit timeout problems

magenta magenta@trikuare.cx
Thu Dec 12 07:03:01 2002

Hi, I'm having the well-known "interrupt line blocked" problem with an
RTL8139D card.  I've read all of the mailinglist archives and Google hits
and everything, and none of the suggestions have worked.  I have tried all
of the following:

- Making sure all power management is disabled, both in the kernel and the
- Making sure APIC is disabled
- Making sure IRQs are actually being allocated to the card and otherwise
  messing around with IRQ and PnP settings in the BIOS
- Sacrificing a baby virgin chicken-goat hybrid and dancing naked under the
  pale moonlight while reciting "Jabberwocky" backwards, both phonetically
  and word-wise
- Trying a different card (I bought two of them; this is for a firewall

The card is recognizing that the media is connected, when I disconnect the
ethernet cable it says so, etc.  Basically, everything works except that it
never actually sends the data out, likely because it never gets interrupts,
because the interrupt line is blocked.

This happens both with rtl8139 and 8139too.

The pertinent dmesg output (using rtl8139):

pci-scan.c:v1.11 8/31/2002  Donald Becker <becker@scyld.com>
rtl8139.c:v1.22 11/17/2002 Donald Becker, becker@scyld.com.
eth0: RealTek RTL8139C Fast Ethernet at 0xd400, IRQ 10, 00:90:47:01:77:f7.
eth0: Transmit timeout, status 0c 0005 media 10.
eth0: RTL8139 Interrupt line blocked, status 5.
eth0: Tx queue start entry 4  dirty entry 0, full.
eth0:  Tx descriptor 0 is 0008a03c. (queue head)
eth0:  Tx descriptor 1 is 0008a03c.
eth0:  Tx descriptor 2 is 0008a03c.
eth0:  Tx descriptor 3 is 0008a03c.
eth0: MII #32 registers are: 1100 782d 0000 0000 01e1 45e1 0001 0000.

Also, on a different occasion it was identical except the descriptors were
all 00002000 (another common one that I've seen in the various

This system is a Celeron 500 with a cheap Intel 440ZX-based motherboard,
running Linux 2.4.19.

Many thanks in advance for any help anyone can give me.  I've already
depleted my precious Red Bull supply trying to solve this. :)