[realtek] 8139 and interface errors

Dave Eidson deidson@bluenorthernsoftware.com
Thu Aug 15 02:21:01 2002

This likely is more of an OS problem, but it was suggested I post the
problem here.
After recently upgrading 2 Debian boxes to the latest stable release
(Woody 3.0),
ifconfig reports many errors on the eth0 device.  As usual, this looked
like a hardware/cable
problem so I first replaced the patch cable from PC to hub.  No change
in errors.  Tried a
different port on the hub. No help.  Swapped out the hub...still lots 'o
errors.  Swapped a
8139 NIC from a non-upgraded (Potato) Debian box, still lots of errors.
Tried different
PCI slots. Regardless of any combination of hardware or cables, the
errors continue.
I can swap any of the error prone components to a Potato box and they
run fine, 0 errors
after at least 24 hours of uptime.  The Woody boxes chalk up 40-100
errors within
2 hours with moderate network usage.  The kernel in use originally was
2.4.4, but I've
tried up do 2.4.18, and back down to 2.2.18 with no changes in the
network errors.
The only other item that may be related is a new message displayed at
boot up
on the recently upgraded machines:

eth0: Setting half-duplex based on auto-negotiated partner ability 0000.

Even with all the errors, there is little indication from a user stand
point that anything
is wrong.  It hasn't seemed to affect intra or internet usage at all, no
errors or problems
with web/mail/etc, etc.  Lastly, the majority of the errors are
predominently on the
RX side, with occasional TX errors.

boot messages:
eth0: RealTek RTL8139 Fast Ethernet at 0xc8000000, 00:a0:a2:21:36:47,
IRQ 10
eth0:  Identified 8139 chip type 'RTL-8139A'

RX packets:35998 errors:101 dropped:7 overruns:60 frame:0
TX packets:36313 errors:0 dropped:0 overruns:0 carrier:0

Any sanity check is greatly appreciated!