[realtek] Does rtl8139 work with kernel 2.4.18?

Siegfried Löschmann loe@loe-online.de
Mon Apr 15 17:04:01 2002

Hi all,

I'm trying to update a diskless client, a tyan dual processor mb with 2 
pentium 200 cpus and a Longshine rtl8139 network card to kernel 2.4.18. Since 
SuSe doesn't ship with Donalds driver anymore I first tried 8139too and it 
doesn't work. Apparently I need the ethernet driver built into the kernel and 
since I am not that familiar with hacking the kernel I had to do some reading 
until I managed to get the rtl8139 driver to compile.
First problem: Compilation results in a naming conflict of 
"pci_find_capabilities". This is exported by pci.o. So I renamed all 
occurences to something else. After this building the kernel worked.
Second problem: When booting the kernel now no adapter is recognised at all.

Has anybody tried rtl8139 with 2.4.18 kernel. @Donald: is this supposed to 

Thanks in advance
Siegfried Löschmann
Schillerstr. 22
21423 Winsen
fon: +49 4171 72415
mobile: +49 162 10 455 43
email: Siegfried.Loeschmann@loe-online.de
web: www.loe-online.de