[realtek] Netgear fa311 problem using natsemi driver

Jeff Washburn jeffwash@us.ibm.com
Tue, 31 Jul 2001 11:09:09 -0500

I'm using a Netgear FA311 NIC card running redhat 6.2 (kernel
2.2.19-6.2.1).  The machine is in switched environment and the switch is
nailed at to 100full duplex.

When I first installed the natsemi.o module everything worked fine.
However, after I reboot the machine, the card no longer receives packets.
The card will transmit, but won't receive.  It randomly works, so I have no
idea what I did that made it work one time, and why it fails another.  It
works when the card is set to auto-negotiation and when I set the card to
100full duplex (using the mii-diag -F 100baseTx-FD <interface> command)

I found a post on your site (Jan 2001-  Ping doesn't respond anymore after
5 good test) that stated he put the debug level to 7 and everything worked
ok.  I did the same thing, and sure enough it worked, but only one time.  I
rebooted the machine and once again, it fails to receive packets.

Here is a portion of the debug statments
     eth1: Interrupt, status 02c0.
     eth1: Interrupt, status 0000.
     eth1: exiting interrupt, status=0x0000.
     eth1: Interrupt, status 0008.
     eth1: Interrupt, status 0006.
          In netdev_rx() entry 0 status was b18000f8.
          netdev_rx() Rx error was b18000f8.

This is repeated throughout the debug messages.

I have no idea how to make the card consistantly work?  Can you help me



Jeff Washburn
I/T Specialist
Global e-business Solution Center
7 Campus Circle
Roanoke, TX 76262
817-962-4001, t/l 522