[realtek] New Problem with my RTL8139

Carlo E. Prelz fluido@fluido.as
Fri Dec 28 02:05:01 2001

	Subject: [realtek] New Problem with my RTL8139
	Date: Thu, Dec 27, 2001 at 08:18:03PM -0500

Quoting Chris Fowler (cfowler@outpostsentinel.com):

> System:
> BCOM ThinClient Platform
> RTL8139C Chipset
> Celeron 300
> 128MB Memory
> Disk is 32MB DOC2000
> It appears that if I assign an ip address in my configuration all is well.
> If I run pump the system seems to stop and I get the following messages
> [root@cas8]# pump
> eth0: Too much work at interrupt, IntrStatus=0x0001.
> eth0: Too much work at interrupt, IntrStatus=0x0001.
> What is most strange is that this does not happen on my older software that
> I load.  If I load my new software I get these error messages.  I never
> modified pump.  I just exec() it from a C program if the user has DHCP
> enabled.  Could I have a memroy buffer issue?

I don't have anything rtl-specific to tell you, but I have experienced
problems with pump: for me it only worked if it was the first ever
network-related program I ran after boot (so that when my friendly ;-)
ISPs dropped the connection I needed to power-cycle to re-enable the
traffic flow). I solved the problem by passing to dhclient, from the
ISC (ftp://ftp.isc.org/isc/dhcp/, in Debian, the package is called

Hope this helps


  *         Se la Strada e la sua Virtu' non fossero state messe da parte,
* K * Carlo E. Prelz - fluido@fluido.as             che bisogno ci sarebbe
  *               di parlare tanto di amore e di rettitudine? (Chuang-Tzu)