[realtek] rtl8139 diag = 0000 'resource or device busy'

lee m orsino leeorsino@yahoo.com
Sun Dec 16 20:43:00 2001

i'm a (semi)newbie using slackware 8.0 and i'm trying to insert the
rtl8139 module. i compiled the sources (with warnings)

warning: '_set_ver' redefined

and rtl8139.c 
warning:ignoring changed section attributes for .modinfo

insmod pci-scan.o
and that worked fine, then:
insmod rtl8139.o

and it said: device or resource busy, insmod errors can be caused by
incorrect module parameters including I/O or IRQ parameters

so i tried to give it a parameter:
insmod rtl8139.o io=0xe000 irq=5
but it said: invalid parameter parm_io
invalid parameter parm_irq

inside /proc/pci there is:
bus 0, device 17, function 0
Ethernet controller unknown vendor, unknown, rev(0)
vendor id=1516 device id=803
medium devsel irq=5
I/O at 0xe000 [0xe001]
Non-prefetchable 32-bit mem @ 0xdc000000

so i ran
./rtl8139-diag -p 0xe000 -t 1 -e
all the fields came up as zeros, including the station address
00:00:00:00:00:00 and the EEPROM checksum 0000

if i run the diagnostic at any other I/O address, all the fields come
up as F's, i.e. FF:FF:FF:FF:FF:FF, vendor=FF, etc etc

it looks like the pci is recognizing the card...but linux and the
driver are not...slackware even comes with this pre-compiled module. i
tried to insert it also, but with the same "resource is busy" error. is
there anything else i can be doing to get linux to recognize the


Do You Yahoo!?
Check out Yahoo! Shopping and Yahoo! Auctions for all of
your unique holiday gifts! Buy at http://shopping.yahoo.com
or bid at http://auctions.yahoo.com