[realtek] Re: Flashing EPROMs on a DFE-530TX+?

Mikkel Lauritsen mlauritsen@nospam.dk
Fri, 17 Aug 2001 22:36:53 +0200

Hi all,

I'm new to the list, and thus I'm unable to reply to the original
mail from Arcadio Sincero - I hope this works out as well.

Anyway, asincero@arcadio.net wrote:

> I have a D-Link DFE-530TX+ NIC.  According to the 8139too driver, this 
> thing uses a Realtek RTL-8139C chip.  This NIC should be able to flash 
> program a flash eprom plugged into its boot rom socket, right?  But
> when I try to flash an Atmel AT29C256-12PC thats plugged into the boot 
> rom socket using the rtl8139-diag utility (with libflash.c linked in)
> I get the following message:
--- snip ---
> ACKKK, this may not be a programmable Flash part!
> Unknown BIOS ROM ID 00 00.
>  Use '-a' or '-aa' to show device registers,
>      '-e' to show EEPROM contents, -ee for parsed contents,
>   or '-m' or '-mm' to show MII management registers.
> Anybody have any ideas?

Nope - this is more of a "Me too!"-post, I'm afraid. I'm trying to do
the exact same thing, except for the fact that I'm using some no-name
8139C based NIC, and I get the same result.

> FWIW, I tried using the DOS Realtek flash utility, RTFLASH.EXE, I got
> from ftp.realtek.com.tw.  However, that quickly turned out to be a
> deadend because when I tried to use it it said it couldn't find the
>  ethernet card

Well, at least here I'm able to tell of different results :-) In
my case rtflash.exe is actually able to see the NIC and detect the
flash prom as well. rtflash.exe doesn't support the 29C256 but it
lists the manufacturer as Atmel and the device code as DC, which
matches perfectly with the information from libflash.c.

So, just to summarize, as opposed to libflash.c, rtflash.exe is
actually able to detect the flash prom, but it won't program it.

I'd actually very much like to have libflash.c detect the prom since
I have a distinct feeling that my chances of getting it to support
the 29C256 is much higher than with rtflash.exe. Would anybody
happen to have any ideas as to why the detection fails? My first
guess was that it might be due to timing problems (not that the
PC is terribly fast - a 500 MHz K6), but inserting 10 us delays
in the detection code made no difference.

I'm going to start going through the documentation for the 8139
to see if I can find any clues as to what might be the problem,
and I'm very willing to test any suggestions that you might

   Mikkel Lauritsen