[realtek] What's 'Interrupt line blocked' mean?

Bill Soudan wes0472@rit.edu
Wed, 18 Apr 2001 05:07:37 -0400 (EDT)

Hi all,

I'm trying to debug a bizarre problem here, so please bear with me.  
Currently, I'm at the 'grasping at straws' phase.

In any case, the problem itself is that under Windows 2000, my network
cards suddenly and randomly die when under constant but (not necessarily
high) load.  Two completely seperate network cards even, a D-Link DFE
530-TX+/rtl8139 and a 3c905b.  Under Linux, the rtl8139 card performs
fine.  Haven't tried the 3c905b yet, but I plan to put it through a
similar test.

Some history - this was happening to me at one point in time, but somehow
either I solved it (unlikely, because I didn't mean to) or it magically
went away (more likely).  I was happy.  Then, about a month ago I received
a new hard drive, and shorted it out while Linux was in the process of
moving partitions to the new drive.  Linux locked hard, and my BIOS
settings were reset.  Ever since then, my network cards have been dying

Finally, to my question - what's this 'interrupt line blocked, status 4'
message mean that I see in my syslog?

    kernel: eth0: RTL8139 Interrupt line blocked, status 4.

Under Linux, with the D-Link card, I receive this message randomly while
I'm doing my stress tests, but the card continues to work without even an
rx or tx error.  

My current reasoning for all this:  while the wonderfully robust Linux
driver recovers gracefully from whatever problem this is (thank you!), the
Windows drivers are unsurprisingly not robust and this causes serious
problems for them.  Furthermore, because it's apparently a generic IRQ
problem, the problem is network card agnostic.  Or, is this a normal
occurance, I shouldn't be concerned with this error message, and my
reasoning is way off?  I don't know enough about IRQs to really understand
the driver source, though I tried :)

Last bit of critical info - I'm using the infamous dual-celeron/BP6 combo,
so this is an SMP system.  Yes, it's overclocked.  I haven't tried
restoring the clock to normal yet, because the problem went away before.  
This is the only problem I have with the board, all my other various
stress tests pass with flying colors (e.g. cd /usr/src/linux; while true;
do; make clean; make -j3; done).  It *is* in my list of things to try,
though, I just haven't made it that far yet.

Any information would be greatly appreciated!