[realtek] Problems with RTL 8139B based card

Christian Zander phoenix@minion.de
Tue, 19 Sep 2000 19:45:59 +0200

Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: quoted-printable

I got a RTL 8139B based Fast Ethernet card as a replacement for
an older NE2K PCI Ethernet card.

The network I'm trying to use the card with is 10baseT. Trying
to make the new card work in that network, I replaced the old
card and bootet a 2.4.0-test8 kernel with the 8139too driver
built into the kernel. The rest of the configuration remained
the same.

On boot, the card seemed to be recognized properly:

eth0: RealTek RTL8139 Fast Ethernet at 0xd0c65000, 00:00:21:2b:de:e7, IRQ 4

It was configured properly by ifconfig and everything seemed
fine at first, but trying to use the interface showed that=20
something is wrong.

I tried pinging one of the machines on the local network, but
was given 'destination unreachable' errors, accompanied with
a myriad of kernel log messages like:

Sep 19 18:30:33 chronos kernel: NETDEV WATCHDOG: eth0: transmit timed out
Sep 19 18:30:33 chronos last message repeated 7 times

I tried forcing the card to 10baseT with the mii-diag tool, but
since this didn't do anything I suspect I either didn't do it=20
right or at the wrong time.

How do I go about fixing the above errors?

 Christian Zander ** N=F6ckersberg 76 ** 45257 Essen ** Germany
 email: phoenix@minion.de * www: www.minion.de * icq: 5322926

Content-Type: application/pgp-signature

Version: GnuPG v1.0.2 (GNU/Linux)
Comment: For info see http://www.gnupg.org