[realtek] NFS problem (using realtek)

Lynn Winebarger lynn@freespeech.org
Fri, 20 Oct 2000 20:49:43 -0600 (MDT)

   I've got a little 4 machine network, with one machine an nfs server and
another running an active webserver (on a separate interface to the
outside world).  The other 2 machines aren't currently being used much
(but will be).  All the NICs hooked up to the 4 machine network are DLink
530TX's with rtl8139 chips.  
   This morning I was copying a few hundred megabytes worth of files over
NFS from machine #3, and the webserver machine's load went through the
roof (because all the httpd processes were in an uninterruptable sleep,
waiting on NFS).  I tried pinging the nfs server, and got back responses
in pairs, where one would be about 0.3 ms, and the other 1000 ms.  I shut
down the copying process, waited a couple of minutes, and pinging the nfs
server got the same results.  I waited a few minutes more, tested again,
same results, rebooted the server, worked fine. (machine #3 didn't
experience any of these problems, though it also uses the rtl8139 driver).
   Anyway, I see similar problems are reported for the rtl8139 driver in
the archives.  I'm using Redhat 6.2, with kernel 2.2.16-3 on the
webserver.  Looks like the rtl8139 driver is 1.07.  Would upgrading to
1.10 fix this problem?  Is there a fix in the near future?
   I'm going to be building a small cluster of webservers using this nfs
server, and buying a bunch of NICs, so I'd like to know whether avoiding
realtek 8139 based cards is necessary (looking at the tulip list, looks
like they're not suffering from the same problem).