rtl8139 full/half duplex

Donald Becker becker@cesdis1.gsfc.nasa.gov
Mon Jul 5 10:50:45 1999

On Mon, 5 Jul 1999, Stephan Henn wrote:

> I got a roblem with my rtl8139 (Kernel 2.2.5,rtl8139 v1.08)
> i tried to run the rtl8139 in fullduplex mode.
> Loading the rtl8139 as a module with the option full_duplex=1
> That make the network in one direction very slow an generates man error on
> the TX !

You can only use full duplex mode when talking to a switch, not a repeater.
The current rtl8139 driver interprets the full_duplex flag as causing the
driver to advertise only full duplex.

> The diagnostic tells me that the card only runs in halfduplex mode.
> So i have to change the parameter of my switchport.

Does your switch autonegotiate?
If so, have you tried it without a parameter?

> Does anyone have any idea what this could be caused by or how to resolve
> it?

There is one section in v1.08 where 'duplex_lock' wasn't considered.
Perhaps you are hitting this code.

Please try v1.08a of 7/5/99 (today) using your current configuration, and
send a report

Donald Becker					  becker@cesdis.gsfc.nasa.gov
USRA-CESDIS, Center of Excellence in Space Data and Information Sciences.
Code 930.5, Goddard Space Flight Center,  Greenbelt, MD.  20771
301-286-0882	     http://cesdis.gsfc.nasa.gov/people/becker/whoiam.html

 | To unsubscribe, send mail to Majordomo@cesdis.gsfc.nasa.gov, and within the
 |  body of the mail, include only the text:
 |   unsubscribe this-list-name youraddress@wherever.org
 | You will be unsubscribed as speedily as possible.