Problem with the RTL8139 driver

Massimo Macucci
Wed Jan 13 14:29:22 1999

Dear linux-realtek experts,

we are having a serious problem with a RealTek RTL3189 PCI card (at least
this is the name with which it is recognized at boot time). After booting,
the system performs normally until, after a time depending on network
activity, the following message starts appearing on the console, and the 
network connection becomes unavailable until a reboot is performed:

"eth0: Transmit timeout, status 0d 2000."

A few times we also got some more information on the console, concerning
the contents of a few registers. I am copying it from a piece of paper 
on which we scribbled it, therefore it may be incomplete or inaccurate:

1 0008003C
2 00080362
3 7008003C
4 0008003C

What makes the whole problem more mysterious (at least for us) is that 
we have two almost identical PCs, the only difference being the size
of the hard disk (4.2 GB on one machine and a bit more than 6 GB on the 
other), and *only one of them* exhibits the problem regularly, while
the other one has exhibited a strange roundtrip delay only once.

The rest of the hardware in the two machines is exactly identical. We 
have tried swapping the ethernet cards, thinking that one was defective,
but the problem remained on the same machine. We have also tried inserting
the card in a different PCI slot, to no avail. The only way to move the 
problem from one PC to the other seems to be that of swapping the hard
disks, which would make one think that it is a software problem.

However both PCs have the very same version of the operating system
(Red Hat 5.2, kernel 2.0.36), installed from the very same distribution.
We have also tried copying the kernel from one PC to the other, but the
problem always remains in the same PC.

The hardware configuration is as follows:

ASUS P2B AGP motherboard
Pentium II 450 MHz processor
384 MB memory
Floppy disk drive
CD ROM drive
Basic 16bit graphic card (I do not have the characteristics handy)

There is no other card, besides the ethernet card, whose hardware
address is  00:20:18:89:4e:d2 (I guess this should be useful to
better identify the type and manufacturer).

I hope this is not something contained in a FAQ, but we have really 
exhausted all ideas...
I would be very grateful to anybody who could give us any hint about how
to tackle this problem.

                                                     Best Regards,
                                                     Massimo Macucci                      Tel. +39 050 568537 
  Dipartimento di Ingegneria dell'Informazione   FAX  +39 050 568522
  Universita` di Pisa,  Via Diotisalvi, 2        I-56126 PISA  ITALY                            
 | To unsubscribe, send mail to, and within the
 |  body of the mail, include only the text:
 |   unsubscribe this-list-name
 | You will be unsubscribed as speedily as possible.