Lanbit Realtek 8139 problems

Jeff Bate
Mon Apr 5 21:14:56 1999

I have a Lanbit Realtek 8139 card that I have been unable to make work
on my dual P133 Micronics M54P board.  The card works fine in a
different machine.  I am using Linux kernal 2.2.1.  
The card appears to be recognized correctly when the rtl8139 module is

	eth1: RealTek RTL8139 Fast Ethernet at 0xfc00, IRQ 0,

The IRQ 0 does not seem right though.  I pulled pci-utils 1.10 and tried
to use setpci to change the INTERRUPT_LINE or INTERRUPT_PIN.  I could
not seem to change either of them.

Here is the output of lspci -vv:

00:0f.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 8139 (rev
        Subsystem: Unknown device 10ec:8139
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 min, 64 max, 32 set
        Interrupt: pin A routed to IRQ 0
        Region 0: I/O ports at fc00
        Region 1: Memory at fedffc00 (32-bit, non-prefetchable)

I also tried the card in different slots to no avail.  Any suggestions?



 | To unsubscribe, send mail to, and within the
 |  body of the mail, include only the text:
 |   unsubscribe this-list-name
 | You will be unsubscribed as speedily as possible.