eithernet driver for SMC EitherPowerII

Eric Sellers esellers@toronto.cbc.ca
Tue Mar 9 13:46:50 1999

I bought two SMC EtherPower II eithernet cards, and
had a problem setting up the first one.

I think I have figured out what it was and wanted to share this
just in case anyone else experiences the same problem.

When I installed the card it defaulted to 100 mbps (the 100 mbps led was
the epic100 driver that came with slackware 2.0.34 would not let me
force it to
10BaseT, so I downloaded the test version. (v1.07 I think)
and used modprobe epic100 options=4 (set it to 10baseT-FD)
This almost worked... the only problem is it would freeze every once in
a while
for a few seconds (10 - 20 seconds)

I used epic-diag and it said it was set for half-duplex even though
the LED on the card said otherwise (the FDX led was on)

When I tried to set it to half-duplex with the epic100 driver it would
not change
modprobe epic100 options=4 full_duplex=0
The software said it was half-duplex but the FDX led was still on

When I tried the other card in the same computer... it worked fine
It auto negotiated to 10BaseT halfduplex and worked like a charm
with the driver that came with slackware 2.0.34
(and all the leds were correct  100mbps led was off and FDX led was off)

So as far as I can tell, its a faulty card, that wont auto negotiate.
It is possible to get the card to go into 10baseT half-duplex mode...
but only in windows using the drivers that were supplied.

Since I know it will work if you poke it right... anyone know how to
force it to half-duplex?
(what register has to be set?)


 | To unsubscribe, send mail to Majordomo@cesdis.gsfc.nasa.gov, and within the
 |  body of the mail, include only the text:
 |   unsubscribe this-list-name youraddress@wherever.org
 | You will be unsubscribed as speedily as possible.