[eepro100] eepro100 does not work correctly after upgrade from RH 7.3 to 8.0

Andre Mueller andre.mueller@himmel-blau.com
Fri Jan 24 09:08:01 2003

Hi Alexander

no I changed nothing in the network, even I installed temporally a NIC from 
planet with the same patch cord etc.  .. it worked fine.

I am looking forward to your report ... many thanks in advance for your effort.

with best regards,

André Müller

'Alexander Tarkhov' wrote:
> Andre,
> I am now writing a short report on how I switched from eepro100 to e100,
> I will send it to you (and to the list) as I finish, but...
> Are you sure you haven't changed anything else while upgrading?
> I mean hub, switch port, patchcord, etc.
> Best regards,
> Alexander Tarkhov
> Andre Mueller wrote:
>> Hello
>> I had running without any problems on a Compaq Desktop en small PC 
>> Redhat 6.2 to 7.3 with the eepro100 for the onboard eth0 interface. 
>> These days I upgraded the OS from RH 7.3 to 8.0 an found that the eth0 
>> does not work again after a simple reboot with the eepro100 driver.
>> the symptoms under are the following:
>> - starting up the system with power on -> eth0 works with yellow LED 
>> for activity is on (referencing the LEDs at the RJ45 connector / green 
>> LED for data traffic) .
>> - rebooting the system -> eth0 goes down (yellow LED is off)
>> - restarting the system -> eth0 is not active (yellow LED remains off) 
>> although dmesg reports eth0 as active (also testing with ifdown/ifup: 
>> after ifdow the eth0 remained inactive also ifup said ok). no data 
>> traffic over eth0 is possible
>> - the only way to reactivated eth0 is to shutdown the system and power 
>> off - on the computer (it is also necessitate me to do it by by 
>> pulling out the power cord).
>> I have contacted Redhat Support and RH Bugzilla, but other than 
>> suggesting to try the e100 driver (the thing worsened with the e100 
>> driver : the yellow LED remained always on but did not work on every 
>> second boot, on every third boot the system crashed.) they had no help 
>> at hand.
>> As I am not so technically proved to get into the deeps of drivers and 
>> NICs, I would be very grateful for any hint how to overcome the 
>> described more than annoying problem as I am using this pc as small 
>> standalone server far from the office and a remote reboot is necessary.
>> here an fragment of dmesg:
>> eepro100.c:v1.09j-t 9/29/99 Donald Becker 
>> http://www.scyld.com/network/eepro100.html
>> eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. 
>> Savochkin <saw@saw.sw.com.sg> and others
>> PCI: Found IRQ 11 for device 00:0a.0
>> PCI: Sharing IRQ 11 with 00:14.2
>> divert: allocating divert_blk for eth0
>> eth0: OEM i82557/i82558 10/100 Ethernet, 00:50:8B:CB:6A:68, IRQ 11.
>>   Receiver lock-up bug exists -- enabling work-around.
>>   Board assembly 307295-101, Physical connectors present: RJ45
>>   Primary interface chip i82555 PHY #1.
>>   General self-test: passed.
>>   Serial sub-system self-test: passed.
>>   Internal registers self-test: passed.
>>   ROM checksum self-test: passed (0x24c9f043).
>>   Receiver lock-up workaround activated.
>> It is also to say that I tried to workout the problem by 
>> enabling/disabling advanced power management and on LAN wake-up in the 
>> bios and also with kernel parameters but with no effect either.
>> Many thanks in advance and best regards,
>> André Müller