[eepro100] eepro and nfs file handle

Traylen, SM (Steve) S.M.Traylen@rl.ac.uk
Wed Nov 6 17:05:20 2002

>>  I have a problem which I have after a lot if investigation
>>  have narrowed down to the combination of eepro100 cards
>>  and particular group of boxes I have. 

>What driver version?
>What is the detection message?

>>  After looking at the tcpdumps by far the most intresting thing
>>  is that I do not seem to be getting a file handle.
>  13:05:04.124247 eth0 > gpplcfg.gridpp.rl.ac.uk.nfs >
>> gppce06.gridpp.rl.ac.uk.2475694225: reply ok 128 lookup fh Unknown/1
>>  I tried the various diagnostics but am not getting very far.

>What diagnostic commands have you run?


Yes I should have been more verbose in this area.

So its a 2.2.19 kernel from redhat on a rh6.2 box.
This appears to have been built with a eepro.c that has
"eepro100.c:v1.09j-t 9/29/99,
though the last modification appears to be

2000 Nov 15 , Changed command completion time and added debug info, ...

>From dmesg,

eepro100.c:v1.09j-t 9/29/99 Donald Becker
eepro100.c: $Revision: $ 2000/05/31 Modified by Andrey V.
Savochkin <saw@saw.sw.com.sg> and others
eepro100.c: VA Linux custom, Dragan Stancevic <visitor@valinux.com>
eth0: Intel PCI EtherExpress Pro100 82557, 00:02:B3:1D:2F:27, I/O at 0xd800,
IRQ 19.
  Board assembly 721383-016, Physical connectors present: RJ45
  Primary interface chip i82555 PHY #1.
  General self-test: passed.
  Serial sub-system self-test: passed.
  Internal registers self-test: passed.
  ROM checksum self-test: passed (0x04f4518b).

The tests I have tried include the eepro test disk from intel which
passed just fine including setting up a responder.


[root@gppce06 /root]# ./mii-diag
Using the default interface 'eth0'.
Basic registers of MII PHY #1:  3000 782d 02a8 0154 05e1 45e1 0001 0000.
 The autonegotiated capability is 01e0.
The autonegotiated media type is 100baseTx-FD.
 Basic mode control register 0x3000: Auto-negotiation enabled.
 You have link beat, and everything is working OK.
 Your link partner advertised 45e1: Flow-control 100baseTx-FD 100baseTx
10baseT-FD 10baseT, w/ 802.3X flow control.
   End of basic transceiver information.


[root@gppce06 /root]# ./eepro100-diag -f -a
eepro100-diag.c:v2.11 8/27/2002 Donald Becker (becker@scyld.com)
Index #1: Found a Intel i82557/8/9 EtherExpressPro100 adapter at 0xd800.
i82557 chip registers at 0xd800:
  0c000050 1f8e90e4 00000000 00080002 182545e1 000005b8
  No interrupt sources are pending.
   The transmit unit state is 'Suspended'.
   The receive unit state is 'Ready'.
  This status is normal for an activated but idle interface.
 The Command register has an unprocessed command 0c00(?!).

which all looks correct to me?

Steve Traylen