[eepro100] fixed again wait_for_cmd timeout in Compaq Presario 2700T with Redhat Linux 8.0

Michael A Chase Michael A Chase <mchase@ix.netcom.com>
Tue Nov 5 12:01:03 2002

On Wed, 30 Oct 2002 08:46:54 -0800 (PST) Michael A Chase <mchase@ix.netcom.com> wrote:

> Since I thought I had fixed the problem in Redhat Linux 7.3, I upgraded to
> 8.0.  The upgrade went normally, but I am again getting the wait_for_cmd
> timeouts.
> On the first boot after install, I was told that the Firewire/IEEE1394 port
> was recognized as new hardware.  I thought it might be causing the renewed
> trouble since it is sharing IRQ 10, but removing the module with rmmod
> doesn't seem to be helping.

There appears to be no connection between this and my problems.

> The timeouts occur occasionally during email downloads and frequently
> during http exchanges.  By pinging my local firewall to detect outages and
> bouncing eth0 when they occur, I can keep the link up enough for low data
> rate work, but major data transfers like ftp downloads or up2date runs are
> slowed badly by very frequent eth0 bounces.
> I tried building the newer network drivers from the Scyld site but received
> numerious compile errors.  I will be trying again today and will send a
> separate email detailing my results.

The RPM would not build for me.  With RedHat 8.0, 'rpm -bb' is no longer
valid, I had to use 'rpmbuild -bb' instead.  The compile still failed

Fortunately, several recent messages from Donald Becker mentioned a
different archive to download and instructions for building eepro100.o from

>  - trying my driver
>  mkdir /tmp/netdrivers/
>  cd /tmp/netdrivers/
>  ncftp ftp://ftp.scyld.com/pub/network/netdrivers.tgz
>  tar xfvz netdrivers.tgz
>  make
>  make install
On the next boot, I got a complaint that Sleep Mode was enabled that
included a mention that I would need eepro100-diag to disable it.
(Thank you, David)

The compile instructions at the bottom of eepro100-diag.c worked and when I
ran 'eepro100-diag -af' I got a message with more details for disabling
Sleep Mode.  They did the trick and I am no longer getting timeouts.

Mac :})
** I normally forward private questions to the appropriate mail list. **
Ask Smarter: http://www.tuxedo.org/~esr/faqs/smart-questions.html
Give a hobbit a fish and he eats fish for a day.
Give a hobbit a ring and he eats fish for an age.