[eepro100] is there a working driver for linux alpha

Michael Barnes mbarnes@compsci.wm.edu
Tue Apr 30 12:09:01 2002

I have a 60 node alpha cluster (SMP with 2 processors in each node)
with eepro100's in them that periodicly have NETDEV timeouts with
moderate file transfers (~45Meg).  I'm using kernel 2.4.9 with the
supplied driver:

eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin

So far I have tried to update the TX|RX_RING_SIZE to 64, updated drivers
from newer kernel sources, and the ones from scyld.  The ones from scyld
that I downloaded today load into the kernel fine, but I only get:

eth0: Transmit timed out: status 0000  0010 at 0/15 commands 0001a000 00020000 00030000.
[ snip ring dump ]
eth0: Restarting the chip...
Command 0070 was not accepted after 10001 polls!
Command 0010 was not immediately accepted, 10001 ticks!

Which repeats until I unload the driver.

I have also tried the e100 driver from Intel, but that does not work
either with Alphas.

So does anyone have any suggestions for getting the eepro100 driver
work on Alpha's or possibly another NIC that has functioning drivers?
(I have also used DECchip based cards, but those too are problematic
with negotiating 100FDX connections, even when forced).



Michael Barnes <mbarnes@compsci.wm.edu>
UNIX Systems Administrator
College of William and Mary
Phone: (757) 207-3611