[eepro100] eepro100: wait_for_cmd timout

Andrea Aime aaime@libero.it
Fri Nov 16 09:04:00 2001

Hi everybody,
I have a problems with my Intel PRO/100 VE integrated ethernet
card on my Acer Travelmate notebook... I've tried to find a solution
without bothering you, but with no luck.

Here is the problem: my card get recognized and the module eepro10
is loaded by the network start script, and it may even work for a while,
as soon as a long data transfer occurs (how long? well, 1 Meg is enough),
the driver hangs with a "eepro100: wait_for_cmd timeout" message,
and the network becomes unreachable and it stays as such unless I reload
the driver (I have compiled it as a module). This is the only message I get
from the driver.

Now I'm using linux kernel 2.4.15pre4, but the same problem occurs
with kernel 2.4.10 vanilla (Linus one) and 2.4.8 (mandrake stock kernel).
I didn't tried ac kernels (sorry... should I do that?).
I also tried to download the source RPM from scyld site, but they don't
(do they support 2.2 series only?)

I also downloaded and compiled Intel drivers, which claims to support
Intel PRO/100 VE, but with no luck (insmod e100 says the device isn't there)
I also downloaded mii-diag programs, and they work... but how can I use
them to solve my problems?
I saw in a previous posting that the problem
may be related to power management, and tried to recompile the kernel
without power management support... no luck, either...
I also tried to increase the counter in wait_for_cmd from 1000 to
2.000.000, well, now I can transfer 10 Mbyte before it hangs...

Any help would be much appreciated :-) Thanks in advance
Best regards
Andrea Aime

PS: please cc me, I'm not on the list (otherwise I'll see your answer
the next day, in the archives...)