[eepro100] can't negotiate the switch

Donald Becker becker@scyld.com
Thu Dec 20 13:05:00 2001

On Thu, 20 Dec 2001, John Howay wrote:

> >> I first left the interface(s) set to autonegotiate, then I forced (on
> >> the fly) 100-FD with mii-diag. I tried this with both adapters. I have
> >> not successfully booted to 100-FD. Could this be my problem?
> >What driver version version?
> >What did mii-diag report?
> mii-diag eth1 returns:
> Basic Registers of MII PHY #30:
> 1000 786d 0000 6b60 01e1 0081 0004 2001
> Basic Mode Control Register 0x1000 : Auto negotiation enabled.
> You have link beat, and everything is working OK.
> Your link partner is generating 100baseTx link beat (no autonegotiation)
> End of basic transceiver information.

This is consistent with a link partner that is set to forced-full-duplex.

> Can you tell me how to check the driver version?

Use 'dmesg', or watch when the driver is loaded.
Note that I do *not* support modified drivers.  Many of the drivers in
the 2.4 kernel have been modified in way that I consider broken.

> >What are the statistics and error counts from 'ifconfig' or 'cat
> >/proc/net/dev'?
> RX packets: 8640 errors: 0 dropped: 0 overruns: 0
> TX packets: 0 errors: 534 dropped: 0 overruns: 0 frame: 0 carrier: 534
> collisions: 0 txqueuelen: 100

Hmmm, this is bad: you are receiving packets, but not transmitting.

> Finally, running eepro100-diag -a returns:
> eepro100-diag.c:v2.06 12/10/2001 Donald Becker (becker@scyld.com)
> http://www.scyld.com/diag/index.html
> Index #1: Found a Intel i82557/8/9 EtherExpressPro100 adapter at 0x2040.
> i82557 chip registers at 0x2040
> 00000000   00000000   00000000   00080002   18217809   00000000
> No interrupt sources are pending.
> The transmit unit state is 'Idle'
> The receive unit state is 'Idle'

> This status is unusual for an activated interface.

You should run this when the interface is up.

> If I run mii-diag without specifying an interface, it brings up the 'default'
> interface, eth0, which I put 'down' with ifconfig. Is there a way to make eth1
> the default?

mii-diag eth1

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993