[eepro100] errors with > 200k transfers

Donald Becker becker@scyld.com
Sun Dec 9 11:50:02 2001

On Fri, 7 Dec 2001, Darrell Schiebel wrote:

> I have a (great) IBM ThinkPad X22. However, I get errors from the
> ethernet card, which the specs say is a "10/100 ethernet on
> Communications Daughter Card / Intel 82562ET chipset". Linux picks the
> eepro100 driver for this card.
> I've tried this with the stock eepro100 driver which comes with 2.4.7-10
> (RedHat) and 2.4.9-13. I also tried the current driver from the Scyld
> website. While the Scyld driver seems to be somewhat of an improvement,
> it still isn't quite right; transfers take an inordinate amount of time
> with the driver repeatedly resetting the chip.

Run 'eepro100-diag' and see if the "sleep mode" bit is set in the
EEPROM.  If so, run
    eepro100-diag -G 0 -w -w -f
to clear the bit.

> My test case was a 9879k file. The current Scyld driver repeatedly
> generates stanzas like:
> Dec  7 09:51:46 dhcp-dyn05 kernel: Command 0080 was not immediately
> accepted, 10001 ticks!
> Dec  7 09:51:56 dhcp-dyn05 kernel: eth0: Restarting the chip...

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993