[eepro100] (no subject)

Chris Jones chris@black-sun.co.uk
Wed, 1 Aug 2001 16:22:05 +0100


* Donald Becker (becker@scyld.com) wrote:
>   http://www.scyld.com/network/updates.html
Ugh, I thought I'd sorted out my kernel includes.

> You likely need to add  -I/usr/src/linux/include  (with the correct
> path

I fixed the problem by symlinking /usr/include/linux and 
/usr/include/asm to the respective directories in /usr/src/linux/include

> What kernel and distribution are you using?
It's Red Hat 7.1, but with a kernel.org 2.4.5 kernel.

> What is the error message?

The most errors come from nfs, which reports things like this:

kernel: nfs: server jade not responding, still trying
kernel: nfs: task 57 can't get a request slot

these errors are spat out every few seconds until I drop the network 

There is an initial burst of data transmitted correctly, but then the 
errors start appearing and the traffic drops to almost nil. I snooped it
with tcpdump and it seemed that my box would send an nfs read request
that was replied immediately with about 5-6 packets at which point the
wire goes silent for about 2 minutes followed by another read request
and 5-6 packet reply. The remote box seems to be querying arp for my IP
after each of these events too (I guess this could be because my box 
appears to have fallen off the network?). Just to make sure the data 
wasn't disappearing down a hole somewhere I checked the activity lights
on the hub (100Mb NetGear hub) and that confirms that the wire is

> What does  eepro100-diag  report about the eepro100 state?

Will that report correctly with the stock kernel 2.4.5 driver? Or with
the interface active?

I did get the pci-scan.o and eepro100.o to compile by sorting out the
includes as mentioned above, but I still get dependancy errors when I
try to load the modules:

-(root@tenshu)-(/opt/home/cmsj/tmp)- uname -a
Linux tenshu 2.4.5 #1 Wed Jul 18 18:50:25 BST 2001 i686 unknown
-(root@tenshu)-(/opt/home/cmsj/tmp)- gcc -DMODULE -D__KERNEL__ -O6 -c
-(root@tenshu)-(/opt/home/cmsj/tmp)- gcc -DMODULE -D__KERNEL__ -O6 -c
-(root@tenshu)-(/opt/home/cmsj/tmp)- insmod ./pci-scan.o
./pci-scan.o: unresolved symbol pci_write_config_byte
./pci-scan.o: unresolved symbol kmalloc
./pci-scan.o: unresolved symbol pci_find_class
./pci-scan.o: unresolved symbol __check_region
./pci-scan.o: unresolved symbol pci_read_config_byte
./pci-scan.o: unresolved symbol pci_read_config_dword
./pci-scan.o: unresolved symbol __ioremap
./pci-scan.o: unresolved symbol pci_read_config_word
./pci-scan.o: unresolved symbol kfree
./pci-scan.o: unresolved symbol pci_set_master
./pci-scan.o: unresolved symbol pci_write_config_dword
./pci-scan.o: unresolved symbol pci_write_config_word
./pci-scan.o: unresolved symbol printk
./pci-scan.o: unresolved symbol ioport_resource

(the .c files are from scyld.com as of last night)

I'm quite confused about the symbol errors because as far as I can see
all of those symbols are listed in the System.map for my running kernel.

I also tried compiling those two modules with -DMODVERSIONS, but that
didn't seem to help either.

Thanks for your time,
Chris "Ng" Jones