[eepro100] Problems at 100fd with eepro100

Vernon McPherron vernon@grooveauction.com
Thu, 18 May 2000 15:10:16 -0600 (MDT)

On Thu, 18 May 2000, Philip Ronzone wrote:

> The problem is not so odd. More than one Ethernet "chip" (NIC) works fine
> with a hub, but has a variety of pronlems with a switch. In fact, I'm
> struggling with that very problem right now. Intel has admitted to problems
> with the NT drivers (82559) and switches, and I'm seeing major problems with
> a switch whenever the driver is set to something OTHER than "auto".
> I'm using the Intel e100.c driver right now, but I'm told this is NOT a
> driver problem, but a hardware issue.
> Intel's "word" for the NT drivers - don't use anything other than auto.
> -----Original Message-----
> From: Vernon McPherron [mailto:vernon@grooveauction.com]
> Sent: Thursday, May 18, 2000 7:45 AM
> To: linux-eepro100@beowulf.org
> Subject: [eepro100] Problems at 100fd with eepro100
> I've got an odd problem, I don't know if anyone else is having the same
> problem, but maybe I could get some help.
> Not too long ago I was using a 100bt hub.  I had no problems.  But just
> the other day I bought a 10/100 switch.  When I hooked it up, I found out
> that I was having SERIOUS problems.  The module loaded fine, and I got a
> link on both the nic and the switch.  But when I tried to ping out, I get
> some crazy nonsense about "Packet Undeliverable".  I thought that a bit
> odd, so I checked out the scyld web site.  I didn't really see anything so
> I decided to upgrade the kernel.  I was previously using 2.3.99-pre6, so I
> patched it to 2.3.99-pre8 hoping that it'd have the latest driver.  After
> rebuilding the kernel, same problem.  I've got a SMP machine and thought
> that might be causing some problems.  I checked /proc/interrupts and it
> seems to be the only one using irq 18.  So I first I thought of doing an
> option=48 to force 100bt full duplex.  It gave the same error.  But some
> of the pings did go through.  But I had about 95% packet loss.  Just to
> test it, I booted into an older non-smp kernel, and yep...  worked
> ok.  Unfortunately I don't want to use just one cpu.  Any ideas?
> -- djVern --
> http://www.grooveauction.com
> _______________________________________________
> eepro100 mailing list
> eepro100@scyld.com
> http://www.scyld.com/mailman/listinfo/eepro100

Thanks.  I'll try intel's e100 driver. 

But if it IS a hardware issue, then will there be a way to write a
workaround or do we just need to be more selective on our switches we buy?

-- djVern --