[eepro100] Problems at 100fd with eepro100

Vernon McPherron vernon@grooveauction.com
Thu, 18 May 2000 08:44:31 -0600 (MDT)

I've got an odd problem, I don't know if anyone else is having the same
problem, but maybe I could get some help.

Not too long ago I was using a 100bt hub.  I had no problems.  But just
the other day I bought a 10/100 switch.  When I hooked it up, I found out
that I was having SERIOUS problems.  The module loaded fine, and I got a
link on both the nic and the switch.  But when I tried to ping out, I get
some crazy nonsense about "Packet Undeliverable".  I thought that a bit
odd, so I checked out the scyld web site.  I didn't really see anything so
I decided to upgrade the kernel.  I was previously using 2.3.99-pre6, so I
patched it to 2.3.99-pre8 hoping that it'd have the latest driver.  After
rebuilding the kernel, same problem.  I've got a SMP machine and thought
that might be causing some problems.  I checked /proc/interrupts and it
seems to be the only one using irq 18.  So I first I thought of doing an
option=48 to force 100bt full duplex.  It gave the same error.  But some
of the pings did go through.  But I had about 95% packet loss.  Just to
test it, I booted into an older non-smp kernel, and yep...  worked
ok.  Unfortunately I don't want to use just one cpu.  Any ideas?

-- djVern --