[eepro100] Problems with Intel PRO/100 CardBus II

Daniel Wolstenholme dwolsten@extremezone.com
Sun, 09 Jul 2000 00:04:11 -0700

Here's the messages I get in /var/log/messages when I insert the card:

cardmgr[433]: initializing socket 0
cardmgr[433]: unsupported card in socket 0
kernel: cs: cb_alloc(bus 2): vendor 0x8086, device 0x1229
cardmgr[433]:   product info: "INTEL(R)", "PRO/100 CARDBUS II",
"MBLA3300", "1.00"
cardmgr[433]:   manfid: 0x0089, 0x0103  function: 6 (network)

Is there anything else to look for?  How do I verify the mapping?

Donald Becker wrote:
> On Tue, 4 Jul 2000, Daniel Wolstenholme wrote:
> > I have an Intel PRO/100 CardBus II (32 bit) on my laptop which I've been
> > trying to get to work with RedHat 6.2 on an IBM Thinkpad 600X.  First I
> > tried using the eepro100 kernel module which was included in RH6.2, and
> > later I tried the newest eepro100 driver version from Scyld.  Both had
> > the same results.  The driver, upon trying to
> > load, gives this error message:
> >
> > eth0: Invalid EEPROM checksum 0x0000, check settings before activating
> > this device!
> > Self test failed, status ffffffff:
> >  Failure to initialize the i82557.
> >  Verify that the card is a bus-master capable slot.
> > PCI: Increasing latency timer of device 02:00 to 64
> What were the other messags?  This is a CardBus card, so there must have
> been a set of messages about the card detection and mapping.
> The problem is the mapping -- the card doesn't exist in I/O space.
> Donald Becker                           becker@scyld.com
> Scyld Computing Corporation             http://www.scyld.com
> 410 Severn Ave. Suite 210               Beowulf Clusters / Linux Installations
> Annapolis MD 21403

Daniel Wolstenholme                    email: daniel@wolstenholme.net
Acura Integra Modification Page           http://dwolsten.tripod.com/
features: Honda articles, rear wiper controller, and many unique mods