[eepro100] Forcing 100Mb Full Duplex on (2) Intel OEM i82557/ i82558.

Graham Wooden GWooden@interland.com
Fri, 29 Dec 2000 12:10:55 -0500

Nope.. DL380. I am not sure if they are the replacements of DL380 though.
Dual PIII 733's...
Anyways, thanks for spearing me on the lecture, I have seen it a few times

That worked great!

You da man!

Graham Wooden, R.H.C.E.
Systems Engineer
678.365.2849 | gwooden@interland.com
Interland, Inc.  | www.interland.com

-----Original Message-----
From: Donald Becker [mailto:becker@scyld.com]
Sent: Friday, December 29, 2000 11:53 AM
To: Graham Wooden
Cc: 'eepro100@scyld.com'
Subject: Re: [eepro100] Forcing 100Mb Full Duplex on (2) Intel OEM

On Fri, 29 Dec 2000, Graham Wooden wrote:

> RedHat 6.2 w/ 2.2.16-3 kernel.
> Compaq DL380, with onboard Intel 100 and PCI Intel 100.

DL380?  Do you mean DL360?  Or are our DL360 systems already obsolete?

> Donald Becker's eepro100 driver, v1.11. Loaded as a module.
> I am trying to get both of these cards, forced to full duplex 100 megabit.
> When loading as a module, only eth0 is being forced correctly, not eth1.
> Here is what my /etc/conf.modules has:
> alias eth0 eepro100
> options eepro100 debug=3 options=0x30
> alias eth1 eepro100
> options eepro100 debug=3 options=0x30

Easy.  You passed the same _single_ option.  Instead do
 options eepro100 debug=3 options=0x30,0x30

This is shown in the example at

> options '0x30' is 100Mb with Full Duplex, right?  
> I even tried to pass full_duplex=1 in the same line, no go.


> Only eth0 is getting full duplex.
> I really need both to full duplex, 100Mb on both cards.

Now, you know that I should give you the "never force full duplex"

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993