Problem with new eepro100B's

Robert G. Brown
Thu Aug 12 17:06:46 1999

Dear List;

I have two brand new Intel Speedo 3 (EtherExpress Pro 100) LAN adapters.
eepro-diag shows them to be an Intel 82557 eepro100B.  This card is
behaving in a most strange fashion.  It works fine at 10 Mbps (if I lock
it to 10 Mbps at boot time, half or full duplex).  However, no matter
which autosensing 100BT switch I plug it into (I've tried four or five
by at least three different manufacturers including Cisco, Intel,
Cabletron and Netgear) the 100B link light refuses to come on and the
NIC refuses to function at 100 Mpbs.

The very curious thing is that this is true from powerup -- it appears
before an OS is even loaded -- and that it seems to happen for both of
the new cards.  I have a whole stack of systems using eepr100's, so I
know that they work and know that they work with our switches; this is
getting a bit frustrating.

I have downloaded both eepro-diag and mii-diag.  The mii-diag program is
showing a basic mode status register containing 0x9801 (when set to
autosense or a 100BT/FD) or 9805 if hard set to 10/FD.  Even when
running 10/FD, though (which works) mii-diag reports "Your link partner
is strange, status 0000."

The contents of the MII registers when running at 10/FD are:

0100 9801 03e0 0000 0000 0000 0000 0000

If I reset the card with mii-diag, this changes to:

3000 9801 03e0 0000 0000 0000 0000 0000

with Link status: not established.

If I reset the card and load the module forcing 100 HD the first word is
2000. If I reset the card and load the module forcing 100 FD the first
word is 2100.  In both of the latter cases I get no link beat and see no

This is quite maddening.  I'm loathe to conclude that the cards are BOTH
bad -- this would be quite bad luck, and they both seem to "work" at 10
Mbps.  However, I need 100 Mbps operation to work, obviously.  Is there
something I am missing, here?  Is there some sort of eeprom interface on
these cards that has to be written to to enable 100 base operation at
powerup?  I can literally unplug a working 100BT connection from one
system and pop it into one of these cards and get nothing -- no link
beat, nada -- until I drop to 10 Mbps, so I'm certain that cables,
switch, software, etc. are all correct and functional.  The only thing I
haven't done is installed them in a Windoze system and tried the drivers
that came with the cards to see if they contain some software magic that
might not yet be in the linux driver.  There is some need to worry about
this; their box advertises that they allow you to "upgrade and change
the adapter's silicon microcode without replacing the card".

For what it is worth, the cards are labelled as from a batch on 5/26/99
(they are really new).

As alway, any help appreciated.


Robert G. Brown	             
Duke University Dept. of Physics, Box 90305
Durham, N.C. 27708-0305
Phone: 1-919-660-2567  Fax: 919-660-2525