Collisions with Intel EtherExpress Pro 100B

Eric Finster
Fri Aug 6 18:42:04 1999

Hi.  I hope this question is not a repeat or just something stupid I
have missed, but I have been fighting this collision problem for days

What happens is this:

I have a linux machine running RedHat 5.2 with an Intel EtherExpress Pro
100B in it.  I am using the updated eepro100.c (v1.08) which I
downloaded from the site.  It is connected to a hub
along with one of our company's embedded PC boards which has an
integrated SMC9194 chip.  I am attempting to bring Linux up on this
board but keep running into this network problem.

Whenever I transfer files between the two computers I get massive
collisions.  I have tried a million configurations to get rid of the
problem.  I have tried the boards under Windows and Linux.  I have tried
removing the SMC board.  The only way I can get rid of the collisions is
under one setup:  running the EEPro under Windows and using the windows
FTP client to transfer files from the SMC computer to the Windows
computer.  However, if I transfer files the other way (from the windows
computer to the SMC one) I still get collisions.

All other configurations result in collisions.  Even two computers
running Linux, each with an EEPro in it gives me collisions.  I have
tried a different hub and new cables.  Nothing seems to work.

I tried playing with the 10/100 settings and the Duplex settings.
Figuring that the hub only ran at 10Mbits, I forced the EEPro to run at
10 using the driver options, and made sure both cards were half-duplex.

Am I just missing something?  Any help would be greatly appreciated.


Eric Finster