New Problem with 1.03

Bryan Jacquot
Fri Aug 21 17:32:56 1998

I have a question concerning a problem we encountered with the 1.03
driver.  We are developing an embedded system with dual Intel eepro100
Ethernet cards.  The problem arose with a test program which we use to
test the functionality of the Ethernet cards.  The test program uses the
SOCK_PACKET type of socket because these tests will run as a loopback
tests when the systems may or may not have IP address.  It also forces
the packets to be sent onto the wire, instead of the protocol stacks
intercepting the packet because it is destined for that machine.

To make a long story short, the test program worked fine with versions
0.36 and .99C (the only two we tried other that 1.03).  However, version
1.03 drops anywhere from 25% to 76% of the packets.  (I'm sending 10000
packets for the test)  The sendto to is able to send all 10000 packets,
however, recvfrom doesn't get all of them.  I'm doing a NONBLOCKING
receive, so I try to receive several times.  If I only try to receive 5
times (the value I've used with the other drivers) then I loose about
75% of the packets.  If I bump the receive attempts up to 1000, then I
only lose about 25% of the packets.  So it seems that there may be a
problem introduced in the 1.03 driver. 

Has anyone seen symptoms like this?  I am willing to distribute the test
program I'm using, so please reply, and I'll e-mail it to you.


Bryan Jacquot,
Extended Systems Research & Development

Phone:  (800) 235-7576 
Fax:      (406) 585-3606