[eepro100-bug] Performance problems ?

Donald Becker becker@scyld.com
Wed, 2 Aug 2000 15:01:32 -0400 (EDT)

On Wed, 2 Aug 2000, Kuht, Mike (M.D.) wrote:

> Has anyone else suffered performance problems with Intel EtherExpress Pro100
> as follows ? 
> I've got a DELL 4300 with Dual Pentium CPU's running Linux 2.2.13 SMP
> Kernel. Originally I was getting the kernel message after periods of heavy
> network load :
> Jul 14 09:26:42 jwsaac14 kernel: eth0: Transmit timed out: status 7048  0000
> at 12273905/12273919 command 000ca000.

This is a generic message meaning "something has gone wrong".
In this case, interrupts are not getting through.
The interface has been running for a while, so I'm guessing that you have
the APIC enabled, and it broke.

The "Damn APIC Bug" has been around for a while, and it doesn't seem to be
fixed.  The solution is to just turn off that code.

> So I've upgraded to the latest version of the eepro100 driver (v1.10) and
> got the message :
> Jul 21 10:56:51 jwsaac14 kernel: eth0: IRQ 20 is physically blocked! Failing
> back to low-rate polling.

Do you get this immediately, or a after running for a while?
I added the polling code and this message because we had problems both
with the initial APIC interrupt assignment, and the eventual problem with
the APIC ceasing to handle interrupts.

> I then saw a message suggesting the "noapic" setting & lilo'ing, so I've
> tried that for fun and although the Ethernet card now uses an interrupt <15
> I still get the same problem :
> Jul 29 21:06:04 jwsaac14 kernel: eth0: IRQ 14 is physically blocked! Failing
> back to low-rate polling.

...and your system is now using the IDE interrupt.  You just can't win, can
you? Change this in the BIOS setup.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Beowulf Clusters / Linux Installations
Annapolis MD 21403