[bproc]Bproc Patch Fail

Sean Dilda agrajag@scyld.com
Wed, 5 Sep 2001 06:15:45 -0400

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Fri, 20 Jul 2001, Anant Kumar Gupta wrote:

> Hi !!
>      I am a newbie in beowulf clustering . As part of my
> training project I have to migrate process from one machine
> to another in Linux. I have been asked to use BPROC for
> this.=20
>     =20
>      After reading the docs I have been trying to patch the
> linux kernel 2.2.10 but except for bproc-0.2.1 none of the
> others (I tried 2.2.2,2.0,2.1.6) patch the kernel
> successfully.
> and after patching when i compile it gives unresolved
> symbols during insmod. the problem is with ksyscall,
> vmadump.=20
> The things i have tried:
> 1. downloaded and compiled source code for kernel 2.2.10 on
> redhat 6.0
> 2. installed caldera 2.3 and doing compilation.
> Is there any better way to achieve this .  Please suggest
> some clean way to achieve this. Apart from Caldera can any
> other distribution be used.

Is there a reason you need to do this from scratch?  If not, I'd suggest
you use Scyld Beowulf (http://www.scyld.com/).  It's an easy-to-use
Beowulf system based on BProc.  It installs out of the box and has very
easy slave node setup and maintnance.

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.1 (GNU/Linux)
Comment: For info see http://www.gnupg.org