[Beowulf] Anybody here still use SystemImager?

Alex Chekholko alex at calicolabs.com
Tue Feb 26 10:03:32 PST 2019

Hey David,

What is the ultimate problem you are trying to solve?  You want to deploy
some identical CentOS 7 machines?

I most recently used the warewulf variant of the OpenHPC distro for
deployment with CentOS 7.x, but my new cluster has no more dependencies on
CentOS, so I've switched to Ubuntu and its MAAS for deployment (and Ansible
for node configuration).

I did spend several unproductive days trying to get warewulf working on
Ubuntu 18.04.

As you know, you have a bazilion options in this space for
DHCP/TFTP/images, etc.

Here's a random option I have not had time to look into:


On Tue, Feb 26, 2019 at 9:56 AM David Mathog <mathog at caltech.edu> wrote:

> Greetings,
> I have been using SystemImager, really just the Boel part, for
> building/rebuilding nodes for ages.  Those were all 32 bit (both the
> nodes and the Boel) and worked fine.  (Yes, I know, who still uses 32
> bit for anything?)  However, the one thing it wouldn't do is
> successfully install a 64 bit image because when it had to chroot
> to run grub2-install it was going from 32 bit to 64 bit, and that
> doesn't work.
> Unfortunately not much luck using the stable 64 bit Boel from
> sourceforge either.
> The binary was from here:
>    systemimager-x86_64boot-standard-4.0.2-1.noarch.rpm
> While the target nodes can PXE boot into boel4 (64) this happens in the
> installation script:
> # format disk, commands not shown
> mount -t xfs /dev/sda3 /a
> mount -t xfs /dev/sda1 /a/boot
> mount -t xfs /dev/sda5 /a/home
> # copy image onto disk, commands not shown
> # install grub
> chroot /a/ grub2-install #details omitted
> Fatal: kernel too old.
> So even though it is a 64 bit to 64 bit chroot, it STILL cannot run
> grub2-install.  The boel kernel is 2.6.21 but Centos 7 is 3.10.0 (or
> thereabouts).
> Tried to build systemimager from github in Centos 7 but that didn't go.
> Description of that here:
>    https://github.com/finley/SystemImager/issues/11
> Tried this too within the running 64 bit Boel:
> cd /a
> export LD_LIBRARY_PATH=/a/lib64
> sbin/grub2-install -h
> sbin-grub2-install: error while loading shared libraries: /a/usr/lib64
> #previous line truncated on edge of screen
> Tried messing about with LD_LIBRARY_PATH but it resulted in "ELF file OS
> ABI invalid" errors.
> What I really need is a version of Boel which will chroot into a Centos
> 7 system.
> Anybody have one?  Failing that, is there another small PXE bootable
> linux distro, more or less like Boel but with a kernel near 3.10, with
> an initrd which loads a target script (by nodename) into busybox and
> runs it?
> Thanks,
> David Mathog
> mathog at caltech.edu
> Manager, Sequence Analysis Facility, Biology Division, Caltech
> _______________________________________________
> Beowulf mailing list, Beowulf at beowulf.org sponsored by Penguin Computing
> To change your subscription (digest mode or unsubscribe) visit
> http://www.beowulf.org/mailman/listinfo/beowulf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20190226/4505b08c/attachment.html>

More information about the Beowulf mailing list